OpenRoads Designer CONNECT Edition SDK Help

LinearPointCollection Class

Defines a Collection of Linear Point

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public class LinearPointCollection : IEnumerable<LinearPoint>, IEnumerable, IDisposable
Inheritance → LinearPointCollection
Implements (LinearPoint), ,

Constructors

LinearPointCollection(LinearPointCollection) Initializes a new instance of the LinearPointCollection class
LinearPointCollection(DPoint3d[], LinearElement) Initializes a new instance of the LinearPointCollection class

Properties

Count Gets the number of linear points that the collection contains
Item  
LinearElement Gets linear element for this collection of linear points
Profile  

Methods

BestFitProfile creates bestfit profile of a point collection
BestFitProfileSimple  
DeletePointByIndex Deletes a point by index
Dispose() Releases all resources used by the LinearPointCollection
Dispose(Boolean) Releases the unmanaged resources used by the LinearPointCollection and optionally releases the managed resources
FilterByVertical Filters vertical in this collection
Finalize (Overrides )
GetEnumerator Gets an enumerator to browse the points of the collection
GetEnumerator2  
GetNativePointArray  
GetVertices Extracts the BGEO points in the collection
GetVerticesWithExtension Extracts the linear points in the collection. if a linear point has an extension point, we privilege it.
GetZAtDistance Computes elevation at a distance
GetZAtParameter Computes elevation at a parameter
GetZFromPointCollection Merges a point array and sets Z
InsertPoint Inserts a point into a collection
Item Gets the linear point at a given location in a collection. Index of the member. Start at 0
Merge Merges a point arrat
OffsetZ Offsets the Z of a collection
Project Projects the points collection of an element on the another element.
ProjectBySegments Projects by Uniform Segment Projection the points collection of an element on the another element.
RemoveDuplicates Removes duplicates in this collection
ResetToUseChordDistanceAlong  
SetAllDistancesAlong  
SetRangeByDistances sets the range of a point collection
SetRangeByParam sets the range of a point collection
SetZForPoint Sets the z of a point

See Also